WHMCS – Mudanças de requisitos PHP em próximas atualizações

Nossa próxima grande atualização do WHMCS vai exigir o PHP 5.6 ou posterior.

Embora este seja o requisito mínimo, é altamente recomendável utilizar as versões mais recentes disponíveis e estáveis de todos os softwares e extensões.

Por que estamos mudando o requisito mínimo?

O PHP 5.5 atinge seu fim de vida no próximo mês. Isso significa que ele deixará de ser suportado pelo PHP e talvez o mais importante, não receberá mais atualizações de segurança. Por essa razão, estamos incentivando todos os nossos usuários para atualizar o mais rápido possível.

Além disso, o aumento do requisito mínimo nos permite tirar proveito dos avanços na linguagem PHP, assim como bibliotecas mais recentes de terceiros e funcionalidades que tornam o desenvolvimento e a manutenção do produto mais fácil e com maior performance.

O que eu faço se estou executando uma versão do PHP mais antiga do que a 5.6?

Nós recomendamos que você atualize o mais rapidamente possível. Se você estiver usando um provedor de hospedagem na web e não um servidor dedicado para sua instalação WHMCS, você vai precisar entrar em contato com o seu provedor de hospedagem e pedir-lhes como você pode atualizar para o PHP 5.6. Futuras versões do WHMCS vão exigir o PHP 5.6 no mínimo, ou seja, você não será capaz de atualizar até que o servidor seja atualizado para a versão do PHP 5.6 ou posterior.

E sobre PHP 7.0?

Nós já estamos desenvolvendo, executando e testando o WHMCS internamente em ambientes com o PHP 7. Nas últimas semanas, o Ioncube lançou versões beta que oferecem suporte ao PHP 7.0. Nós continuamos a monitorar e observar com interesse o progresso do desenvolvimento do Ioncube para o PHP 7.0 e estamos empenhados em oferecer o WHMCS com suporte para o PHP 7.0, logo que o ionCube necessário for disponibilizado.

Como sempre, se você tiver quaisquer dúvidas ou preocupações, por favor, sinta-se livre para entrar em contato com a nossa equipe de suporte.

— Fonte: Upcoming PHP Requirement Change | WHMCS

Na Alphimedia os clientes possuem total liberdade em alterar a versão, extensões e configurações do PHP por conta de hospedagem através do cPanel.

Confira o nosso tutorial: Como alterar a versão, extensões e configurações do PHP no cPanel?


Leia mais:
Portas usadas pelo cPanel

Fechar